Using Microsoft Powerpoint to Create Logic Models

Creating “Program Logic Models” for use in evaluations is a common activity for many social service organizations. However, one of the biggest challenges in creating and maintaining good logic models is technological – knowing the procedures and options for creating them with available computer software. An inability to efficiently create and format logic models so that they are clear, readable, and shareable can mean that program planning and evaluation is delayed or derailed.

Many people use Microsoft Powerpoint for presentations and other reasons, but may be unaware of the many features that make it a very powerful tool for creating visual diagrams. This information guide provides a range of tips and tricks that are essential in creating and logic models and other visual diagrams.

1.0. Setting up your Page

Powerpoint pages that contain your model can be as large as you want them to be. Usually the default page size (8.5” x 11”) is a bit too small – a small page means small boxes and smaller fonts. To increase the page size, go to File>Page Setup and adjust the Width and Height. Set the page to 45 cm x 30 cm (as a starting size) and select the Landscape orientation. But you can make it any size you like.

The default slide design (when you first open a new Powerpoint document) will usually have template boxes in place that say “Click to Add Title” and/or “Click to Subtitle”. Select them by clicking on their border and press delete to remove them. You won’t need them.

2.0. Making and Manipulating Boxes:

Along the bottom left of Powerpoint is a menu called Autoshapes. There are many different shapes to choose from. Autoshapes all function just like text boxes that you might use in MS-Word. In the Autoshape menu, go to Basic Shapes and click on a shape you want to use (the “rectangle” is commonly used). Your cursor will turn into a cross-hair. Click and drag the cross-hair across the page and a box will form. Then click on the box so it is highlighted (i.e., little “handles” will appear at each corner). Begin typing and text will be added.
Tip: Often when you click on a menu, not all the options are visible. You have to click on the two little arrows (circled at right) to expand the menu so that it displays the full range of options.

Tip: Because logic models can be complex and busy, the font you choose will often be quite small. This requires zooming in so you can see what you're doing. You can adjust the zoom level by using the **Zoom** drop down menu (the one that allows you to select the % of page size). A great shortcut, however, is to press **Ctrl** while wheeling the scroll button (if you have one) on your mouse. This will zoom the page in and out. This feature also works in MS-Word.

2.1. Formatting boxes and text

Clicking in the middle of a box will allow you to edit the text. Double-clicking on the border of a box brings up a dialogue box called **Format Autoshape**. A number of tabs allows you to manipulate a number of features of the box. The **Colours and Lines** tab will allow you to change the fill colour and line color (the line referring to the border of the box). Logic models are easier to read if some categories (e.g., activities) are a different colour than others (e.g., short-term outcomes).

If you want to have a simple text-based title (i.e., text without the box) simply select “no fill” and “no line” in the color selection menus.

The **Size** tab allows you to select the specific size of the box. We often use this option when we want to make multiple boxes identical in size. The **Text Box** box tab allows you to control how the text is situated in the box. For example, the **Text Anchor Point** allows you to specify the vertical and horizontal alignment of the text within the box. Two options should be checked (i.e., enabled): **Word wrap text in AutoShape** and **Resize Autoshape to fit text**. These two features automatically wrap and resize your box so it accommodates your text. If you prefer to size the box in a particular way (which can be important in tight, busy logic models), leave the **Resize** feature unchecked, so you can size it manually.

---

1 Right clicking anywhere on the page brings up a “context menu”. These menus provide a variety of common actions that are otherwise accessed in the regular drop down menus at the top of Powerpoint. For example, right-clicking on an object is another way to access the **Format Autoshape** dialogue box.
2.2. Selecting, sizing, and moving boxes

Selecting multiple boxes: Clicking on a box selects it so you can work with it. If you want to select multiple boxes (or “objects” – a rectangular box is but one of many types of objects in Powerpoint), put your cursor on a blank area of the page, left-click and drag. This will create a “marquee” – basically an expanding rectangle. Any object within the rectangle when you release the left mouse button will become selected. Any changes you make will apply to all the selected objects. This is great to quickly change the fill colour, font type and size, or other elements of many boxes at once. If you want to select multiple individual boxes (for example, a box in the top right and bottom left of your page), click the first box so its selected, then press Ctrl-left click to select other individual boxes.

If you want to change the properties of your selected boxes using the Format AutoShape options (e.g., to change the fill color, or to change their borders from solid lines to dashed lines), hang your cursor over top of any one of the selected boxes and double-click. The Format AutoShape dialogue will open. Any changes you make will similarly be applied to all the selected boxes.

Sizing boxes: When a box is selected, it has little “handles” on its corners and on the middles of each side. Clicking and dragging the top/bottom will change the height; the left or right will change the width; the corners will change the geometric size. Note that Resize Autoshape to fit text should be disabled in order to size a box in this way.

Moving boxes: Select the box by clicking on its border, and drag it to the location on the page you want.

Copying boxes: A great way to ensure consistent formatting in your model is to copy and paste an existing box, and simply replace the existing text with new text. Copying and pasting functions are identical to those in MS-Word. Highlight the box and either use the Edit menu or right-click menu to access copy/paste functions; or use Ctrl-C and Ctrl-V (shortcuts for copy and paste, respectively)

Default for new objects: In the bottom corner of the Format AutoShape dialogue box, there is a checkbox that allows you to set the default for new objects. If this option is checked, the fill and line colour, type, and style will be retained when a new shape is created.

2.3. Quick resizing of fonts

Shortcut to increase/descrease font size: Highlight the text in a box (you can also select the box itself by clicking on its border, it doesn’t matter) and then press Ctrl-Shift-> to increase the font or Ctrl-Shift<- to decrease the font. You can also do this with multiple selected boxes (as above), which is a quick way to increase/decrease the font of text within many boxes at once. Of course, you can also change the font in the font size drop down menu.
3.0. Connecting Objects:

One of the frustrations of Powerpoint users when trying to draw flow charts is that they use the “draw arrow” function (there’s a little arrow button at the bottom of the screen). However, when a box is moved, the associated arrow does not remain connected to the box. It has to be moved as well as its own separate object. It becomes very finicky and time-consuming to arrange all the boxes and arrows so that they remain visually linked on the page. To solve this problem, there is a menu called Connectors in the AutoShape menu. The Connectors menu contains options to create straight, right-angled, and curvy connecting lines. These lines can have single- and double-headed arrows or no arrows at all.

This menu is so useful to making logic models that we put the menu on the bottom of Powerpoint where it is always accessible.

3.1. Setting up the Connectors Menu for Quick Access

To access the Connectors menu, click on AutoShapes at the bottom of the screen Then click and drag the menu (i.e., put the cursor over the upper part of the menu – it will highlight) onto another part of the screen. The menu will now be “floating” on its own on the screen. Next, click and drag the menu to bottom task bar of the screen (see screen shot below). The menu will now be permanently accessible at the bottom of the screen. Many other menus can also be arranged in this way.

Don’t use this “draw arrow” button to make connecting arrows
3.2. Making Connections

To make a connection between objects (e.g., from an activity to an outcome), click on the desired connector (most often the one-way, straight arrow). Your cursor will become a cross-hair. Hang the cursor over the top of the first box and four handles will appear. Click and drag from the first box to the second. Four handles will appear on the second box. Position the cursor over the desired handle (i.e., where you want the arrow to connect) and let go. The two boxes are now joined. Try moving the boxes around. As you can see, the arrow remains connected to both boxes. You can also click on the tip of an arrow and drag it to another handle on the same box or on another box. This little feature makes PowerPoint an essential tool for creating flowcharts and diagrams, such as logic models.

**Formatting arrows**: Much like boxes, if you double-click on the arrow, you will access the Format Autoshape dialogue box. Here you can adjust the weight (thickness) of the line, change the arrow head type or direction, and change the line style (solid, dotted, dashed, etc.).
4.0. Other Important Editing Functions:

If you know the basic features of drawing and formatting boxes and connecting them with arrows you have the essential tools to build logic models. However, there are a number of other very useful tricks and trips that allow you to make models more quickly and to make them better looking.

4.1. Grouping Objects

It is very common in logic models that multiple activities will lead the same outcome; or the reverse, where, one activity will lead to multiple outcomes. This can create a busy mess of arrows, such as in the model excerpt below:

Activity 1 leads to outcomes 1 to 3.
Both activities lead to outcome 3.
Activity 2 also leads to outcomes 4 to 6

To reduce the number of arrows and improve clarity, we often try to cluster objects in our models. This is accomplished visually by drawing a box over top of the shared outcomes (or activities, as the case may be) and then linking a single arrow from the activity to the larger box, as shown below.

Notice that a unique arrow from Activity 2 to Outcome 3 specifically is necessary to retain all the links in the first diagram.

This grouping looks nice visually, but it is can be frustrating if you want to move things around – you have to move many different objects individually. Powerpoint solves this with the grouping function.

Highlight all the objects you want to group (in this case, O1, O2, O3 and the bigger box that contains them). Go to the Draw menu in the bottom left of the screen. Select Group. Powerpoint will convert the cluster into a single object. The text in this new object can still be edited. If you wish to undo this function, select the new object, go to the Draw menu and select Ungroup. Grouping is very useful in general. Often if a big chunk of a model is completed, we’ll group all the objects (everything – boxes arrows, titles, etc.) and just move the whole group out of the way so we can focus on other parts of the model.
One caution: When you are selecting a group of objects, the grouping may include connector arrows. Once arrows become part of a grouped object, they lose their connecting properties – they will not stay connected to other non-grouped objects if the grouped object is moved around. If this sounds complicated, simply include an arrow as part of a grouping and then move the new object around – you’ll see what we mean.

4.2. Ordering Objects

If you tried the grouping function above you may have immediately experienced an annoying problem – the new box you created has covered up the objects you were grouping. In general, the newest object created in Powerpoint becomes the “top object” on the screen, and when it is moved around it will move over top of any other object. Imagine the screen is your desk, and the objects are papers. Each new paper put on your desk will necessarily cover the others, unless you do some ordering. Powerpoint has just such an ordering function.

For example, I want to group O1 to O3 by putting them in a larger rectangular box, but this newly created rectangle is obscuring the outcomes. Select the large rectangle, go to the Draw menu and then activate the Order menu. You then have a number options, such as Send to Back, Bring to Front, Send Backward, and Bring Forward. The first two commands sends the object all the way to back or front (it becomes the bottom or top object of all the objects on the screen). The second two commands brings the object “one forward” or “one back”, in relation to the other objects. In this case, select Send to Back.

Similar to the Connectors menu, you can click and drag this submenu and put it at the bottom of powerpoint where it will stay permanently for easy access.

Tip: One way to avoid having to order objects is to make the box transparent to begin with, so it doesn’t cover anything up. In the Format Autoshape dialogue box (accessed by double-clicking the border of an object), select “no fill” for the fill Color under the Colors and Lines tab.
4.3. Aligning and Arranging Objects

For those of us who get picky about appearances – wanting things to line up perfectly straight, and so on – there are a couple of features worth knowing about. First of all, you may notice that you cannot make really fine movements of an object; it sort of jumps small increments on the page. If this is the case, it is because **Snap to Grid** is enabled. This function can be useful. It means that the borders of any object will, as you move them, automatically align with the vertical and horizontal gridlines. In the accompanying screen shot, for example, O2 to O4 are aligned vertically and O4 to O6 are aligned horizontally along the gridlines. To enable or disable **Snap to Grid** got to the **Draw** and select **Grids and Guides**. In the dialogue box select (or unselect) “Snap objects to grid”. If you select “Display grid on screen”, the gridlines will appear. If this remains unselected, the grid is “still there”, but the lines are not visible. “Drawing guides”, the third check box, places one vertical and one horizontal line on the screen that you can move around to help you to visually align objects.

All that said, we don’t use **Snap to Grid** too much. We often prefer to have fine control over the positioning of objects, which is sometimes the only way to get arrows straight or ensure there are spaces between objects in a very dense model (i.e., sometimes **Snap to Grid** will push objects together, because the increments that you can move are not fine enough).

There is another very quick way to align objects:

Go to the **Draw** menu and select **Align or Distribute**. In the example on the right, we would likely select **Align Top**, to make all four objects align along their top borders. The objects will align with the top-most object in the group (in this case, Activity 3).

Experiment with the other alignment and distribution options – many come in handy.
The “Nudge” function: Sometimes you may need to move objects in very small increments, just to line things up, create separations between objects, and/or get your model to look just the way you want it. The Nudge function does this for you. Go to the Draw menu and select Nudge. It is necessary to once again drag the menu so it floats independently on the screen. If you want to make the Nudge menu available permanently whenever you open powerpoint, drag it to the bottom of the screen. Once you have selected your object(s), click on the direction that you wish to “nudge” the object. The object(s) will move in very fine increments in the selected direction (in Snap to Grid mode, the object(s) will move according to the spacings of gridlines).

This may seem like a superfluous little function, but we use it quite a bit, especially in dense models where we have to portray a lot of information in small spaces.

4.4. Rotating Objects

Occasionally it may be helpful to rotate objects. This is useful when you want a textbox to appear vertically or when you are using block arrows (these are arrow shapes in the AutoShapes menu – have a look) that need to be pointed in a specific direction. When you select any object, a green handle appears above it. Hang your cursor over top of this green handle and you will see a rotate icon appear. Click and drag your mouse right or left to rotate the object clockwise or counterclockwise, respectively.

You can also go to the Draw menu and select Rotate or Flip. This provides the option to flip to the mirror image of the object, rotate it 90 degrees, etc.
5.0. Printing and Reproducing your Models

Printing logic models can be challenging and unpredictable, often because printer settings will vary depending on the printer that you are using. However, we have a few common tips.

5.1. Printing your Model

First, it is important to remember that the Page Setup function (see section 1.0.) does not specify the Paper Size. Paper Size is specified in your local printer options. For example, you could set up the page size to be the standard letter size of 8.5” x 11”, or 5” x 7” picture size, but then have it print out on poster sized paper several feet high and long. Similarly, you could set the page size quite large (like we do when creating models) and then print it on 8.5” x 11” paper. Powerpoint will adjust the scale accordingly, as long as you tell it to.

Go to the menu File>Print. The Print dialogue box will appear. Ensure that you are printing “Slides”. Go to Properties to select your paper size. This will link you to your generic printer options. Logic models often (but not always) suffer for room in the right-left direction, presuming you have them set up with activities across the top flowing downwards to short- and long-term outcomes. For this reason, its recommended that you use 8.5” x 14” paper in a landscape orientation. If you have the capability to print 11” x 17” paper, by all means use it. This means that you can use a smaller font in your Powerpoint document, which frees up room in your model. Powerpoint will "scale up" the model to the 11” x 17” size, making it readable (i.e, the true font of 10 pt in the document, for example, is magnified when printing).

The key option to enable is Scale to fit paper. This will ensure that Powerpoint shrinks or expands your model to fit whatever paper size you have chosen.
5.2. Exporting your Model to MS-Word

You may want to be able to put your model, or portions of your model, right into the body of your reports or other documents. One way is to select, copy, and paste all the objects together right into MS-Word. This approach is problematic because the formatting can be affected, creating larger or smaller boxes or fonts that do not match the model as it appears in Powerpoint. Another option is to convert your model to a picture file. We have found the best quality conversion is called “Enhanced Window Metafile” and its very easy to do.

In Powerpoint, go to File>Save As. In the Save As dialogue box, scroll down in the Save as Type option and select “Enhanced Window Metafile” (this is simply a picture file, similar to a jpeg). You will get a prompt asking you to either save all the slides (each slide will become a separate .emf file) or the “current slide only”. Select the latter. Your model will be saved as picture.

Open your Word document and position your cursor where you would like the model to go. Go to the Insert menu and select Picture>From File. Navigate to the desired .emf file and select it. Your model will be inserted in your Word document.

5.3. Formatting your logic model in MS Word

Initially, you will be unable to move the picture (the model) around in your document, because of the way it is formatted. In order to move the picture around in your document more easily, double-click on it. A Format Picture dialogue box with multiple tabs will appear. Select the Layout tab then select Square. You can also select the horizontal alignment of the picture (left, right, centre, etc.). Now you can move the picture more easily (by clicking and dragging). Text in your document will wrap around it where there is space. The corner handles will allow you to shrink or expand the size of the picture. The side and top/bottom handles will allow you to stretch it as well, but stretching often reduces the quality of the picture.
5.4. Cropping your Logic Model

Sometimes you may want to only display parts of your model. It is fairly easy to crop the picture once it is in Word. Double-click on the model to access the Format Picture box and select the Picture tab. Under the Crop section, adjust the measurements to crop whatever amount of the original picture you want. This may require some trial and error to get it just right.

---

Index

1.0. Setting up your Page

2.0. Making and Manipulating Boxes
   2.1. Formatting boxes and text
   2.2. Selecting, sizing, and moving boxes
   2.3. Quick resizing of fonts

3.0. Connecting Objects
   3.1. Setting up the connectors menu
   3.2. Making connections

4.0. Other Important Editing Functions
   4.1. Grouping Objects
   4.2. Ordering Objects
   4.3. Aligning and Arranging Objects
   4.4. Rotating Objects

5.0. Printing and Reproducing your Model
   5.1. Printing your model
   5.2. Exporting your model to MS-Word
   5.3. Formatting your model in MS-Word
   5.4. Cropping your logic model

---

Contact Us

This document was prepared by Jason Newberry and Andrew Taylor. For more information on building program logic models, please contact us at the Centre for Community Based Research (jason@communitybasedresearch.ca & andrew@communitybasedresearch.ca), or visit www.communitybasedresearch.ca